“Unable to load shared library” Error in LDK Linux masterhasp

While running masterhasp in linux, an error message may be encountered as “Unable to load shared library”

This is because masterhasp requires some packages and .so files to be installed on the system.

The exact file name may vary. Few examples:
libstdc++.so.6
libSM.so.6
libjpeg.so.62

These are generic files and are not LDK product specific.

Resolution:
The required packages can be downloaded and installed from linux online repository using ‘yum’ command.

Example:  yum –y install libSM.so.6